Switchless MD2

MomoRetro
Messages : 164
Enregistré le : dim. 15 déc. 2019 17:18
Contact :

Switchless MD2

Message par MomoRetro »

Salut !
Je rencontre un petit problème dans l'installation du switchless que j'ai acheté ici même .
Globalement, en suivant ce schéma :
download/file.php?id=6366
Avec le bouton reset j'arriverrive a switcher entre 2 régions (Jap et EU) même pas 3 (je suppose US) , pourtant j'ai bien la led qui passe du rouge au vert et au orange en restant appuyer.
Par contre ça a l'air bloqué en 50Hz que je sois en région Jap ou Eu.
(Dans le menu info de leverdrive, je suis soit en EU PAL soit en JAP Pal en fonction de la couleur de la led)

Mais si j'utilise ce schéma :
https://dragoncity17.files.wordpress.co ... 2/md21.png
Je reste bloqué en region Jap (ou US je ne sais pas, en tout cas pas EU car mon megacd m'indique que le système n'est pas en EU) et en 60Hz je pense.
Par contre , le bouton reset n'a aucun effet (pas de changement de couleur ni region ni fréquence).
Du coup je comprend pas trop si quelqu'un a une idée d'où peut venir le souci ? PIC défectueux ? Programmation du PIC ?

Question subsidiaire :
Quel rôle a la résistance soudé a la diode ? Car sans la soudé ça semble fonctionner de la même manière en soudant la patte du milieu directement au pcb de la console (au niveau de l'ancienne diode).
Et enfin pas possible de switcher juste la fréquence indépendamment de la région (par exemple pour jouer a un jeux Pal en 60Hz sur un megacd pal)?
:)

Pour info j'ai une carte mère PAL MD2 Va1.8

Merci d'avance pour votre aide car là je tourne en rond :D

Avatar du membre
darius
Administrateur du site
Administrateur du site
Messages : 47775
Enregistré le : sam. 6 janv. 2007 00:00
Localisation : Boissy Aux Cailles
Contact :

Switchless MD2

Message par darius »

je sais pas quoi te dire car je viens d'en faire 2 avec le méme matos et le méme schema et qui fonctionnent parfaitement !
je pense que tu a une piste mal coupée ou un truc du genre ... fait des photos de tout ca :)

le changement de frequence sans changement de zone a été abandonné , rendant le kit compatibles TOUTES MD1 et MD2 !
car ca ne servait a rien = le pal en 60Htz c'est la position US ! y'a aucune difference :D

pas besoin de la resistance du shema originel si tu soude la cathode commune sur la carte mére direct ,
certain suppriment la resistance juste a coté mais je trouve trop eblouissant

le schema de dragoncity n'est pas adapté au pic que je vends , tu dois suivre le schema du forum
Image
MES VENTES (allez fouiller ;) )
Ca Vient d'Arriver (abonnez vous a ce topic pour etre prevenus des mises en vente)
RESERVATIONS (postez y ce que vous voulez acheter et vos questions)
EVALUATIONS (parceque vous aimerez savoir a qui vous envoyez vos sous :D )

MomoRetro
Messages : 164
Enregistré le : dim. 15 déc. 2019 17:18
Contact :

Switchless MD2

Message par MomoRetro »

Ok bizarre, pourtant j'ai testé la continuité des 3 pistes coupées et c'était ok.
Est ce que en appliquant le mauvais schema ça a pu corrompre le pic ?
Ce weekend je me replongerai dessus et je ferai des photos si ça se règle pas.
On est d'accord que comme pour les autres consoles, si j'étais en 60Hz , j'aurai plus de bandes noires ?
Et questions au passage : avec ce mod switchless , on perd définitivement la fonction initiale du bouton reset (redémarrage de la console)?

Avatar du membre
darius
Administrateur du site
Administrateur du site
Messages : 47775
Enregistré le : sam. 6 janv. 2007 00:00
Localisation : Boissy Aux Cailles
Contact :

Switchless MD2

Message par darius »

MomoRetro a écrit :Est ce que en appliquant le mauvais schema ça a pu corrompre le pic ?
a mon avis non , d'autant que tu a commencé avec le bon schema ?
MomoRetro a écrit :Ce weekend je me replongerai dessus et je ferai des photos si ça se règle pas.
j'attends ca de pied ferme :D
MomoRetro a écrit :On est d'accord que comme pour les autres consoles, si j'étais en 60Hz , j'aurai plus de bandes noires ?
exact , en tout cas beaucoup moins : sur les cynematiques y'en a toujours mais bien plus petites
MomoRetro a écrit :Et questions au passage : avec ce mod switchless , on perd définitivement la fonction initiale du bouton reset (redémarrage de la console)?
je crois pas ? c'est pas en donnant une impulsion courte ?
Image
MES VENTES (allez fouiller ;) )
Ca Vient d'Arriver (abonnez vous a ce topic pour etre prevenus des mises en vente)
RESERVATIONS (postez y ce que vous voulez acheter et vos questions)
EVALUATIONS (parceque vous aimerez savoir a qui vous envoyez vos sous :D )

MomoRetro
Messages : 164
Enregistré le : dim. 15 déc. 2019 17:18
Contact :

Switchless MD2

Message par MomoRetro »

Je t'avoue que j'ai pas commencé par le bon schéma :2352593487:
Mais vu que le 5v et le gnd reste sur les même pin pour les 2 schéma je pense pas qu'il peut y avoir une incidence. L'autre éventualité (hormis problème de soudure / coupure de piste) c'est qu'à force de souder et dessouder le pic a trop chauffer ?
Je testerai avec un nouveau pic pour sécuriser de ce côté là.
Pour ce qui est du reset, non quelque soit le temps resté sur reset ça ne redémarrait pas, mais ça peut être lié au fait que mon installation n'est pas totalement fonctionnelle.
Et du coup, pour anticiper quand ça marchera correctement. Sans le système de Switch 50/60hz indépendant du changement de région , je ne pourrai pas lire de jeux Pal en 60Hz sur megacd , si ? Vu qu'à priori le megacd est zoné, si je charge le bios JAP/US du megacd grace a leverdrive pour mettre ma Megadrive en 60Hz, mes jeux PAL ne se lanceront pas. Donc soit obligé de lancer les jeux Pal megacd en 50hz soit avoir des version JAP/US pour profité du 60Hz. J'ai juste ?
Merci :)

Avatar du membre
darius
Administrateur du site
Administrateur du site
Messages : 47775
Enregistré le : sam. 6 janv. 2007 00:00
Localisation : Boissy Aux Cailles
Contact :

Switchless MD2

Message par darius »

je n'utilise pas d'everdrive , juste le freebios sur le MCD et le switchless sur la MD alors je ne sais pas du tout !
en plus j'utilise tout les jeux a leur frequence d'origine vu qu'un certain nombre deconnent quand on veut faire autrement :D
alors oui : si tu tiens au 60htz prends les jeux US
mais il n'y a pas de difference de vitesse entre un jeu 50 affiché en 50 , et un jeu 60 affiché en 60 !

pour le reste je parle en theorie car je ne l'utilise jamais , j'eteins et je rallume ,
mais si j'y pense , la prochaine fois que j'en ai une branchée je testerais :)
Image
MES VENTES (allez fouiller ;) )
Ca Vient d'Arriver (abonnez vous a ce topic pour etre prevenus des mises en vente)
RESERVATIONS (postez y ce que vous voulez acheter et vos questions)
EVALUATIONS (parceque vous aimerez savoir a qui vous envoyez vos sous :D )

MomoRetro
Messages : 164
Enregistré le : dim. 15 déc. 2019 17:18
Contact :

Switchless MD2

Message par MomoRetro »

Ok, donc la différence ne se jouera pas sur la vitesse mais juste les bandes noires (pas comme saturn quoi, ou la vitesse change pas mal !)
Ça marche, c'est sympa tu me tiendra au courant si tu test ça. ;)
Et j'en viens a une autre problématique cette fois-ci sur le méga cd lol avant de créer un topic pour ça , peut-être que tu as la réponse.
C'est tout con : j'ai voulu démonter le megacd (2) , j'ai démonté les vis au dos jusque là normal mais bizarrement impossible de séparer la coque sup et inf alors qu'il n'y a plus de vis ! :1079716639:
ça a l'aire d'être retenu au milieu et après avoir regardé les tuto, je constate que moi j'ai la plaque sur le megacd que j'arrive pas a enlever ! Je sais pas si ça retient les 2 coques !?
Je mets une photo pour que tu constate , je vois pas de vis pour enlever la plaque, ça bouge pas !
Fichiers joints
IMG_20200130_012432.jpg

Avatar du membre
Darkey
Messages : 274
Enregistré le : ven. 26 avr. 2019 13:48
Contact :

Switchless MD2

Message par Darkey »

Salut,
T'as juste à faire glisser la plaque vers la gauche, si ça coince c'est parce qu'il y a longtemps qu'elle est en place, force un peu.

MomoRetro
Messages : 164
Enregistré le : dim. 15 déc. 2019 17:18
Contact :

Switchless MD2

Message par MomoRetro »

Ok merci pour ton retour, javais essayer même de faire levier avec un tournevis mais ça bougeait pas lol
Du coup pour éviter de tout casser en faisant le bourricot, je préférais demandé conseil.
Ça marche je vais retenter ça : juste glisser sur la gauche. :)
Du coup j'espère que c'est bien la plaque qui empêche l'ouverture , sinon je vois pas :/

MomoRetro
Messages : 164
Enregistré le : dim. 15 déc. 2019 17:18
Contact :

Switchless MD2

Message par MomoRetro »

Merci Darkey , en forçant ça a finit par coulisser effectivement, c'était bien ça qui empêchait le démontage de la coque ! Du boulot en plus en attente pour ce weekend du coup ! :) Merci

Avatar du membre
Darkey
Messages : 274
Enregistré le : ven. 26 avr. 2019 13:48
Contact :

Switchless MD2

Message par Darkey »

De rien amuse toi bien :D

MomoRetro
Messages : 164
Enregistré le : dim. 15 déc. 2019 17:18
Contact :

Switchless MD2

Message par MomoRetro »

Bon aller comme prévu des photo du montage , par contre a force de refaire et défaire les soudures sont pas très belles.
En tout cas, avec ce montage la console reste bloqué en US 60hz, et le bouton reset ne fait plus rien : pas de changement de couleur de led ni fonction reset :
PicsArt_02-01-02.18.55.jpg
PicsArt_02-01-02.21.13.jpg
PicsArt_02-01-02.19.38.jpg
PicsArt_02-01-02.18.55.jpg
J'attend vos avis dexpert moi je sèche ;)

MomoRetro
Messages : 164
Enregistré le : dim. 15 déc. 2019 17:18
Contact :

Switchless MD2

Message par MomoRetro »

PicsArt_02-01-02.23.34.jpg
PicsArt_02-01-02.24.04.jpg

Avatar du membre
darius
Administrateur du site
Administrateur du site
Messages : 47775
Enregistré le : sam. 6 janv. 2007 00:00
Localisation : Boissy Aux Cailles
Contact :

Switchless MD2

Message par darius »

moi je vois deja 2 erreurs :

ton fil orange (vert sur le schema) , a l'endroit ou tu a fait la coupe tu semble avoir coupé une derivation de la piste
ton fil vert (orange sur le schema = pourquoi tu te complique a inverser les couleurs :D ?) il va pas sur une piste coupée qui méne aux pattes arrieres , ca fait pas la méme chose ! il va sur les 2 pattes AVANT RELEVEES ! (lift from PCB and connect)

deja remets en ordre en respectant mon schema a la lettre et ensuite tu teste :D
et tu revient nous dire !!!
Image
MES VENTES (allez fouiller ;) )
Ca Vient d'Arriver (abonnez vous a ce topic pour etre prevenus des mises en vente)
RESERVATIONS (postez y ce que vous voulez acheter et vos questions)
EVALUATIONS (parceque vous aimerez savoir a qui vous envoyez vos sous :D )

MomoRetro
Messages : 164
Enregistré le : dim. 15 déc. 2019 17:18
Contact :

Switchless MD2

Message par MomoRetro »

Merci pour ton retour :)
C'est vrai que pour les couleur, il manquait un câble du coup j'ai fait avec un moi et j'ai mélangé effectivement lol
Pour la dérivation coupé, normalement j'ai vérifié pas de discontinuité, mais c'est vrai que j'ai coupé trop près du "carrefour" :D
Pour les pattes du bouton reset, c'est bien la piste des pattes avant que j'ai coupé. C'est déjà ça lol
Du coup faut que je dessoude complètement le bouton reset pour y souder le fil sur une des pattes que je relis a l'autre avec un fil ?
Désolé pour les questions "bêtes" :D

MomoRetro
Messages : 164
Enregistré le : dim. 15 déc. 2019 17:18
Contact :

Switchless MD2

Message par MomoRetro »

Alors petit retour : j'ai dessoudé mon fil vert et je l'ai fixé a une des 2 pattes avant (celle proche du port manette) du bouton reset. J'allume la console, quand j'enlève le fil vert de la patte avant ça fait défilé les couleur de la led et quand je refixe le fil vert ça stop la led et change bien de région (Pal / Us et Jap).
Vu que j'ai coupé la piste des pattes avant du reset et que je fixe mon fil vert dessus ça devrait faire le même effet nan ? Le problème c'est qu'en appuyant sur reset ça fait pas défiler les couleur , faut que j'enlève physiquement le fil de la patte avant pour initier le défilement de région et que je le remette pour stopper :/

Avatar du membre
darius
Administrateur du site
Administrateur du site
Messages : 47775
Enregistré le : sam. 6 janv. 2007 00:00
Localisation : Boissy Aux Cailles
Contact :

Switchless MD2

Message par darius »

parcequ'il y a plusieurs conducteurs qui arrivent sur les pattes avant , dessus et dessous , pour ca qu'il est plus simple de les lever
Image
MES VENTES (allez fouiller ;) )
Ca Vient d'Arriver (abonnez vous a ce topic pour etre prevenus des mises en vente)
RESERVATIONS (postez y ce que vous voulez acheter et vos questions)
EVALUATIONS (parceque vous aimerez savoir a qui vous envoyez vos sous :D )

Avatar du membre
KITCHEN34
Modérateur
Modérateur
Messages : 5189
Enregistré le : mer. 13 juil. 2016 22:46
Contact :

Switchless MD2

Message par KITCHEN34 »

il y a 2 fichier epprom pour programmer les puces switchless, t'es tu renseigné sur le tiens. Ca peu changer fondamentalement la câblage :)

MomoRetro
Messages : 164
Enregistré le : dim. 15 déc. 2019 17:18
Contact :

Switchless MD2

Message par MomoRetro »

Ok vu ma situation, en levant les 2 pattes avant ça devrait revenir en ordre normalement ? :)
@kitchen, la puce switchless vient de chez Darius ;)

Avatar du membre
darius
Administrateur du site
Administrateur du site
Messages : 47775
Enregistré le : sam. 6 janv. 2007 00:00
Localisation : Boissy Aux Cailles
Contact :

Switchless MD2

Message par darius »

KITCHEN34 a écrit :il y a 2 fichier epprom pour programmer les puces switchless, t'es tu renseigné sur le tiens. Ca peu changer fondamentalement la câblage :)

c'est celle qui va avec mon schema :)
switchless-MD2.jpg
switchless-MD2.jpg (119.05 Kio) Vu 287 fois
Image
MES VENTES (allez fouiller ;) )
Ca Vient d'Arriver (abonnez vous a ce topic pour etre prevenus des mises en vente)
RESERVATIONS (postez y ce que vous voulez acheter et vos questions)
EVALUATIONS (parceque vous aimerez savoir a qui vous envoyez vos sous :D )

Avatar du membre
Darkey
Messages : 274
Enregistré le : ven. 26 avr. 2019 13:48
Contact :

Switchless MD2

Message par Darkey »

Désolé j'aime bien poser des questions bêtes, mais quand tu appuies sur reset, tu laisses appuyé ?

MomoRetro
Messages : 164
Enregistré le : dim. 15 déc. 2019 17:18
Contact :

Switchless MD2

Message par MomoRetro »

Nouveau retour :
J'ai dessoudé le bouton reset complètement pour remonter les 2 pattes avant complètement, ressouder les 2 pattes arrière et relié le fil aux pattes avant. Effectivement ça marche mieux !
Du coup en restant appuyé ça change bien de région, et en relâchant ça fixe la région donc ça fonctionne comme prévu ! :) Merci a vous :)
Par contre, vous êtes d'accord sur le fait que le bouton reset ne fait plus redémarre la console ? (Même en appuyant très rapidement ça ne fonctionne pas).
Et enfin, je reste avec ma problematique de Switch fréquence indépendamment de la région (pour megacd), y a moyen de reprogrammer le pic sans investir une blinde ? :)

Avatar du membre
darius
Administrateur du site
Administrateur du site
Messages : 47775
Enregistré le : sam. 6 janv. 2007 00:00
Localisation : Boissy Aux Cailles
Contact :

Switchless MD2

Message par darius »

tu a vraiment repontés les coupes inutiles ? chuis etonné que tu puisse pas reseter !
tiens bha je vais en brancher une tout de suite pour verifier :D

tu veux reprogrammer le 16F630 ? tu ferais mieux de faire dezoner ton MCD !
Image
MES VENTES (allez fouiller ;) )
Ca Vient d'Arriver (abonnez vous a ce topic pour etre prevenus des mises en vente)
RESERVATIONS (postez y ce que vous voulez acheter et vos questions)
EVALUATIONS (parceque vous aimerez savoir a qui vous envoyez vos sous :D )

Avatar du membre
darius
Administrateur du site
Administrateur du site
Messages : 47775
Enregistré le : sam. 6 janv. 2007 00:00
Localisation : Boissy Aux Cailles
Contact :

Switchless MD2

Message par darius »

pour reset tu tiens une demi seconde et ca reset sans changer la zone :)
pour changer de zone c'est une seconde

pour les jeux MD pal que tu veux passer en 60 tu regle sur US (orange) apres
pour les jeux MCD pal que tu veux passer en 60 (pourquoi faire ?) je sais pas mais tu peux les rezoner US avant gravure (ou enregistrement sur everdrive ?
Image
MES VENTES (allez fouiller ;) )
Ca Vient d'Arriver (abonnez vous a ce topic pour etre prevenus des mises en vente)
RESERVATIONS (postez y ce que vous voulez acheter et vos questions)
EVALUATIONS (parceque vous aimerez savoir a qui vous envoyez vos sous :D )

MomoRetro
Messages : 164
Enregistré le : dim. 15 déc. 2019 17:18
Contact :

Switchless MD2

Message par MomoRetro »

Non j'ai pas reponté mais au final la seule coupe inutile est celle qui relié les pattes avant , du coup inutile de reponter vu que les pattes sont soulevées. J'ai tord ?

Répondre

Retourner vers « Vos Problémes à Résoudre »

Qui est en ligne

Utilisateurs parcourant ce forum : TxetxenFighter et 4 invités